BlueSnap Logo

Status Page

Processing Delays - European Acquirer

Minor incident Production Environment - Production: Web Services (API) - Production: BuyNow Hosted Pages
2021-01-11 15:45 PST · 17 hours, 30 minutes, 37 seconds

Updates

Resolved

We have a confirmation from the acquiring bank that the transaction processing time is back to normal; Our team is reviewing the recent transactions and we will keep on monitoring the upcoming traffic, to make sure this issue is completely resolved.

January 12, 2021 · 09:15 PST
Investigating

One of our European acquiring banks is reporting technical issues on their end, causing processing delays that affect some of the BlueSnap transactions.

Our teams are working with the Acquirer to resolve the issue - we will continue to update this incident.

January 12, 2021 · 04:49 PST

← Back